Today I mostly .....

Any topics of general interest (not lada related), post them here.
User avatar
Zelandeth
Platinum
Platinum
Posts: 1919
Joined: Wed Jul 31, 2002 3:40 am
Location: Milton Keynes
Contact:

Re: Today I mostly .....

Postby Zelandeth » Wed Oct 17, 2018 9:48 pm

The new crankshaft pulley for the Xantia arrived this morning. Comparing old and new it's pretty clear that the old one is well and truly knackered.

Image

It's very clear that the outer edge has moved relative to the "hub" - the result of course being the belt being pulled out of line.

Image

Swapping things out was literally a case of "de-tension belt, unbolt, remove pulley, put new pulley on, clean bolt, apply thread lock, tighten bolt, re-tension belt, tidy up."

Which was about the long and the short of it. It does appear to have resolved things for the most part. I've marked the pulley and bolt and will be keeping an eye on it to make sure it's staying bolted up before I put the wheel arch liner back in.

Image

The oil leak - which looks massively worse here than it is - the car has never left so much as a single drip of oil where it's parked - is from the cam cover. I'll get it replaced at some point, though it's pretty well buried, so it may well be a while before it gets to the top of the to do list.

Tomorrow's task is probably going after this with a set of good quality hose clips.

Image

I know that there's some air getting into the system, and the perpetual film of oil there tells me that one of the return hoses is weeping slightly...so hoping that going over things properly will resolve both of these issues.

Lastly I fixed this...

Image

Which took me all of 30 seconds to get the screw out, remove dead battery, find replacement (2x CR2032) and put it back together again. So why on earth had I put it off since mid May when the remote stopped working?!?
LOZ: Oddball cars, lighting information, and anything else I remember to upload!
Current fleet: 96 Citroen Xantia Activa, 93 Lada Riva 1.5EFi Estate, 90 Mercedes 208D Autotrail Navajo, 73 &75 AC Model-70s.

User avatar
Zelandeth
Platinum
Platinum
Posts: 1919
Joined: Wed Jul 31, 2002 3:40 am
Location: Milton Keynes
Contact:

Re: Today I mostly .....

Postby Zelandeth » Sat Oct 20, 2018 9:44 pm

Hard to believe we're only a couple of weeks away from a full year that I've had the Activa in my fleet.

Means it's service time. Picked up fresh oil, oil and air filters and a new set of wiper blades (as my use of the windscreen washers yesterday made it abundantly clear how knackered the set on the car was). The rear has a fitting type that's quite hard to find these days so that was a case of dismantling and rebuilding it with new rubber.

Oil and filter will be done tomorrow, air filter was done today though.

Image

Not the worst I've seen by a long shot, but definitely due a change.

Have already got a pollen filter in stock too, so will stand on my head in the passenger footwell to change that too in the morning.

Other task for tomorrow is to investigate why the van appears to have decided to start peeing fluid out the clutch slave cylinder. Oh, and the funny squeaking noise from up front, which also appeared newly today...just hoping it's not the alternator basically...
LOZ: Oddball cars, lighting information, and anything else I remember to upload!
Current fleet: 96 Citroen Xantia Activa, 93 Lada Riva 1.5EFi Estate, 90 Mercedes 208D Autotrail Navajo, 73 &75 AC Model-70s.

User avatar
Zelandeth
Platinum
Platinum
Posts: 1919
Joined: Wed Jul 31, 2002 3:40 am
Location: Milton Keynes
Contact:

Re: Today I mostly .....

Postby Zelandeth » Tue Oct 30, 2018 11:18 pm

The Lada has always in my ownership had an issue with the fact that you could only ever use the windscreen washers twice or three times before the whole system would clog up and need to be dismantled and declogged.

Main issue was slime growing in the tank.

Image

It also had issues in that the lid had split (they all do that) which had left the pump dangling by its hoses.

So today took it out and gave it a thorough clean, while I was there I bolted the pump back onto it. The lid was reinforced by wrapping a cable tie around it, clamping it to the rim of the tank. It's not pretty but works.

Much cleaner...

Image

...aaaand back in place.

Image

Much better. Hopefully will be able to use the washers more than twice now, and have one less thing to worry about come MOT time...most importantly though it won't bug me every time I open the bonnet.

The obvious question looking at that photo though is "where has a large chunk of my coolant gone?"

...Guess that will be first on the list once this weekend's festivities are out of the way.
LOZ: Oddball cars, lighting information, and anything else I remember to upload!
Current fleet: 96 Citroen Xantia Activa, 93 Lada Riva 1.5EFi Estate, 90 Mercedes 208D Autotrail Navajo, 73 &75 AC Model-70s.

User avatar
Zelandeth
Platinum
Platinum
Posts: 1919
Joined: Wed Jul 31, 2002 3:40 am
Location: Milton Keynes
Contact:

Re: Today I mostly .....

Postby Zelandeth » Wed Oct 31, 2018 11:19 pm

With the knowledge that the Activa has a 300-ish mile trip tomorrow I wanted to give it a once over. Also wanted to finish the service I started the other day.

Okay...first off drain the oil, five minute job with no mess because I'm lazy and use a pump. Oil filter required 15 minutes of faffing around to get off simply because it's a royal pain to get at, even when you've already done it twice.

Image

It would be easy if there wasn't a boost pipe in the way to the left and a million high pressure hydraulic lines to the right.

Once I convinced it to move it was a simple matter of spin it off, spill oil all over the front of the engine because it's mounted the wrong way up, and stick the new one on. Then fresh oil in, start up and check the level. Having measured what came out, this was where we were first try.

Image

While I was in there I checked that the crankshaft pulley bolt hadn't unscrewed itself, it looked fine. So put the wheel arch liner back in.

Image

While giving things a wipe down I spotted something that obviously wasn't as it should be...

Image

So *that* would be why a little while ago I suddenly started to be able to hear the turbo wastegate going *pssschooo* on every gearchange.

Nothing for it with a trip halfway up the country the following day, pulled it off, got some good quality duct tape in there and wrapped some cable ties around it so the tape can't unravel.

Image

Better solution would have been self amalgamating tape, but I couldn't find it. So duct tape it is. The hose has gone very hard, so replacement is probably the only long term solution. It's basically just a glorified elbow though, so I'm sure a silicone replacement could be sorted easily enough (as knowing PSA the original hose will be long since NLA).

Last task for the day was to clear the detritus out of the boot and to give the leather a quick skim over with the leather conditioner.

Looks better!

Image

Really need some new floor mats in the front.

Image

If I've got to spend several hours stuck in a queue on the M6, I may as well do it in a clean car interior that smells nice.
LOZ: Oddball cars, lighting information, and anything else I remember to upload!
Current fleet: 96 Citroen Xantia Activa, 93 Lada Riva 1.5EFi Estate, 90 Mercedes 208D Autotrail Navajo, 73 &75 AC Model-70s.

User avatar
Zelandeth
Platinum
Platinum
Posts: 1919
Joined: Wed Jul 31, 2002 3:40 am
Location: Milton Keynes
Contact:

Re: Today I mostly .....

Postby Zelandeth » Wed Nov 07, 2018 12:02 am

So the Activa provided us with lovely comfortable for the 400 ish mile trip to and from Scotiacon over the weekend. Didn't miss a beat I'm glad to report. Can also vouch for those newfangled Valeo "Hybrid" wiper blades are brilliant.

Time for a bit of time for the van. Initially set out to investigate the non-functional heater blower. Wondered if the blower assembly would be accessible from under the dash with the engine cover removed.

Image

That would be a no. Annoying...looks like it will be a dash top off job then.

Oh well. While I've got the cover off (it's a bit of a faff to get it right out the vehicle) I may as well get the only oil leak of any consequence sorted, the timing cover has been weeping from the front offside corner.

Sure enough, with the cover off it was obvious that the old gasket has turned to plastic and was cracking around that corner. New one was only £12 from Mercedes themselves so wasn't worth messing around with eBay nonsense or playing supplier roulette.

Have a look at this...

Image

Isn't that the cleanest engine top end you've ever seen?

Definitely seems to suggest that the story of the van having no expense spared on maintenance by the original owner.

Need to give the front and side of the engine a scrub down to confirm, but it appears to now be oil tight again, be nice to have it all cleaned up before the MOT next month. Oh...need to sort the exhaust though. Missing hanger on one box (so it buzzes like mad) and a huge hole in the other.

Oh...any tidy up that radio wiring... it's a mess, and now I've seen it I can't unsee it.
LOZ: Oddball cars, lighting information, and anything else I remember to upload!
Current fleet: 96 Citroen Xantia Activa, 93 Lada Riva 1.5EFi Estate, 90 Mercedes 208D Autotrail Navajo, 73 &75 AC Model-70s.

User avatar
Tom.
Site Owner
Posts: 657
Joined: Tue Feb 12, 2008 1:08 am
Location: Liverpool
Contact:

Re: Today I mostly .....

Postby Tom. » Wed Nov 14, 2018 10:53 pm

Got my hands on some original UK Lada seat cover sets and floor mats. Also got a Niva 17i Cossack complete seat set. ( in need of a deep clean ) :)

Image

Image

Image
97 Niva 1.7i
2107 Riva Sport
2104 Estate 1500


Return to “General Interest”

Who is online

Users browsing this forum: No registered users and 2 guests